解决bootstrap 在360兼容模式错位问题

按下列步骤执行,可解决bootstrap在各版本IE浏览器中的兼容性问题:

  • 有没有正确调用远程地址
    即只要是IE9以下,就调用两个专门的js:
    <!-- HTML5 Shim and Respond.js IE8 support of HTML5 elements and media queries -->
    <!--[if lt IE 9]>
    <script src="<a%20href="http://apps.bdimg.com/libs/html5shiv/3.7/html5shiv.min.js%22%3E%3C/script%3E" rel="external nofollow" target="_blank" rel="nofollow">http://apps.bdimg.com/libs/html5shiv/3.7/html5shiv.min.js"></script>
    <script src="<a%20href="http://apps.bdimg.com/libs/respond.js/1.4.2/respond.min.js%22%3E%3C/script%3E" rel="external nofollow" target="_blank" rel="nofollow">http://apps.bdimg.com/libs/respond.js/1.4.2/respond.min.js"></script>
    <![endif]-->
  • 调用方法正不正确
    不要用file://或@import形式引用respond.min.js或respond.js或css文件;
  • 针对浏览器的内容做标识(使用meta标签调节浏览器的渲染方式)
    bootstrap不支持IE兼容模式,为了让IE浏览器运行最新的渲染模式,将添加以下标签在页面中
    <meta http-equiv="X-UA-Compatible" content="IE=edge,Chrome=1" />
    IE=edge表示强制使用IE最新内核,chrome=1表示如果安装了针对IE6/7/8等版本的浏览器插件Google Chrome Frame(可以让用户的浏览器外观依然是IE的菜单和界面,但用户在浏览网页时,实际上使用的是Chrome浏览器内核),那么就用Chrome内核来渲染。关于此meta标签的具体说明,可参见StackOverflow上的精彩回答,<meta>标签高人的英文解释可以参看
    <a%20href="http://stackoverflow.com/questions/6771258/whats-the-difference-if-meta-http-equiv-x-ua-compatible-content-ie-edge-e" rel="external nofollow" target="_blank" rel="nofollow">http://stackoverflow.com/questions/6771258/whats-the-difference-if-meta-http-equiv-x-ua-compatible-content-ie-edge-e
    <meta http-equiv="X-UA-Compatible" content="IE=9" />解决bootstrap 在360兼容模式错位问题
    内核控制Meta标签,因为目前国内的主流浏览器都是双内核,故而添加meta标签来告诉浏览器使用什么内核来渲染页面
  • IE8不支持container的几个属性
    IE8不完全支持box-sizing:border-box与min-width, max-width, min-height或max-height的一起使用.所以,v3.0.1的bootstrap中对container的类,已经不再使用max-width了。
  • JS与CSS的引入顺序导致的问题
    必须先引用css在引用js
    <link rel="stylesheet" type="text/css" href="bootstrap.min.css" rel="external nofollow" media="screen"/>
    <script type="text/javascript" src="js/respond.min.js"></script>
  • DOCTYPE前后有空行
    <!DOCTYPE html>
    这里有空格也不行,要去掉空格
    <html>
  • 可以手动修改bootstrap.css
    如果您使用的是bootstrap2.1.1,修改了navbar-inner{ filter:none}可解决问题,如果使用的是3.0+版的,没有这段代码了,详细介绍请看连接
    <a%20href="http://stackoverflow.com/questions/12460190/bootstrap-navbar-does-not-show-in-ie8" rel="external nofollow" target="_blank" rel="nofollow">http://stackoverflow.com/questions/12460190/bootstrap-navbar-does-not-show-in-ie8
  • 在IE11下测试通过,但是在IE8下测试,有发现一个问题placeholder不被支持
    下面是解决IE支持placeholder的方法
    本文引用的jquery是1.11.1测试通过,先引用jquery
    <script type="text/javascript" src="<a%20href="http://code.jquery.com/jquery-1.11.1.min.js%22%3E%3C/script%3E" rel="external nofollow" target="_blank" rel="nofollow">http://code.jquery.com/jquery-1.11.1.min.js"></script>
    也可以用其他的jquery版本
    再引入<script type="text/javascript" src="js/jquery.placeholder.js"></script>
    jquery.placeholder.js这个文件的下载地址<a%20href="https://github.com/mathiasbynens/jquery-placeholder" rel="external nofollow" target="_blank" rel="nofollow">https://github.com/mathiasbynens/jquery-placeholder
    然后再文件中加入一下代码
    <script type="text/javascript">
    $(function () {
    // Invoke the plugin
    $('input, textarea').placeholder();
    });
    </script>
收藏 (0) 打赏

感谢您的支持,我会继续努力的!

打开微信/支付宝扫一扫,即可进行扫码打赏哦,分享从这里开始,精彩与您同在
点赞 (0)

1. 本站所有资源来源于用户上传和网络,如有侵权请邮件联系站长!
2. 分享目的仅供大家学习和交流,您必须在下载后24小时内删除!
3. 不得使用于非法商业用途,不得违反国家法律。否则后果自负!
4. 本站提供的源码、模板、插件等等其他资源,都不包含技术服务请大家谅解!
5. 如有链接无法下载、失效或广告,请联系管理员处理!
6. 本站资源售价只是赞助,收取费用仅维持本站的日常运营所需!
7. 如果您也有好的资源或教程,您可以投稿发布,成功分享后有M币奖励和额外收入!

模板下载吧 WP技术 解决bootstrap 在360兼容模式错位问题 https://www.mbxzb.com/blog/file/wordpress/2038.html

从明天起,做一个幸福的人,喂马、劈柴、周游世界…

常见问题
  • 本站所有资源版权均属于原作者所有,这里所提供资源均只能用于参考学习用,请勿直接商用。若由于商用引起版权纠纷,一切责任均由使用者承担。
查看详情
  • 最常见的情况是下载不完整: 可对比下载完压缩包的与网盘上的容量,若小于网盘提示的容量则是这个原因。这是浏览器下载的bug,建议用
查看详情

相关文章

评论
暂无评论
点击按钮快速添加回复内容: 支持 高兴 激动 给力 加油 苦寻 生气 回帖 路过 威武 友军 顶贴
官方客服团队

为您解决烦忧 - 24小时在线 专业服务

解决bootstrap 在360兼容模式错位问题-海报

分享本文封面